Hotel Management System
HMS 2003

HMS is an integrated software for hotels. The functions of this system covers all the hotel operation functions and issues huge number of management reports that support the hotel managers in control and follow up.
HMS is modular software. It's components covers the operation and management needs of the hotel.
HMS is installed on one computer or on a network of unlimited number of computers. Workstation operating system is windows 98 or higher. Data Server could be Windows NT, 2000 or any network operating system.
HMS offers unlimited number of rooms and unlimited number of outlets.
In spite of the high performance and functionality of this software, the price is VERY LOW.
HMS Features:
  • Any relational DBMS
  • Any Interface Language
  • Web Enabled
  • Better Performance
  • More Functionality

    • 4 Abdel Haleem Newara; Al-Nozha Al-Gadida;
    Cairo; EGYPT
    Tel: +20(10)5234609 / +20(2)6249262
    email: eahelal@gawab.com


HMS Modules

Hotel Management System
HMS 2003

Integrated Software for HOTELS
Modules:
  • Front Office
  • Outlets
  • Management Reporting
  • Group reservation
  • Room Service
  • Basic Data Module
  • --------------------
  • Items catalogue
  • Purchasing Module
  • Inventory Module
  • General Accounting Module
  • Application Users Module


Application Users System

HMS 2003 Modules
Name: | Application/Authentication User System
Code: | AUS
Varsion: | 1.0.0
Issue Date: | January 2003
Function:
 This is a common module for all integrated application system like HMS, RCM, IPS, ... etc. The system adminstrator uses this application to define usres of the other modules and give them authorization for the modules functions. He also defines the basic data of the company like address, registration data, ... etc.
Requirements:
AusDB AUS Database

Order a CD of the whole HMS 2003 for only the price of postage and handeling.


Hotel Basic Data

Name: | Hotel Basic Data
Code: | HBD
Version: | 1.0.0
Issue Date: | January 2003
Function:
 Define the hotel to HMS system. It defines Meal prices, Taxes, Room Types, Rooms, Outlets, Outlet Items, Nationality table, and Maintenance Items. It also Defines Special prices for any client that will be selected automaticaly for the guests belonging to him.
Requirements:

AUS | Application User System Application and database
ICM | Item Catalog Management Application and database
HMSDB | Hotel Management System database
GAS | General Accounting System

Order a CD of the whole HMS 2003 for only the price of postage and handeling.


Hotel Front Office - HFO

Name: | Hotel Front Office
Code: | HFO
Varsion: | 1.0.0
Issue Date: | January 2003
Function:

This module supports the front office functions like reservation, check in, check out, guest deposits. It include a lot of inquiries and reports about front office operations.

Function List:
Room Layout showing rooms status for 10 days.
Room Occupancy (Reservation, check in, day use>.
Room Guest (Enter and update guest share).
Guest Personal Data (Update guest personal data).
Guest Notes (Enter and update guest's notes).
Room Pricing (change standard room prices).
Enquiry about standard room prices for reservation.
Guest Deposites (Enter and update guest down payments).
Outlet Exceptions (Execlude some outlet services from room account to paid in cash).
Guest Variant Expenses (Enter and update guest services out of the standard outlet services).
Guest History (Display guest history).
Guest List (Display and print In-House Guests).
Reservation List (Display and pring resrvation list).
Room Account Statement (Print Shift closing account).
Change Guest Room (To move a guest from room to room).
Client Account Statement (Print Client account for a specified period of for a specific reservation).
Guest Account Statement (Display and print guest down payments).
Requirements:

AUS | AUS Application and database
GAS | GAS Application and database
HMSDB | HMS database
HBD | Hotel Basic Data Module
Module Installation:

Copy all database file in folder (db) of CD to a database folder in the database server (local or remote in another computer of the network).
Remove the read only attribute of all the database files.
Databases are designed with Microsoft Access Engine. The user may convert the database files to any other relational database like SQL, ORACLE, MySql, ... etc. taking into consideration any modifaction required like for example the date fields must be long dates that include the date and time.
Define Data Source for each database file using ODBC Data Source Manager. The data source name must be the first three letters in the database file name. For example the data source name of the file AusDb.mdb must be (aus), and the file HmsDb.mdb must be hms, ... etc.
If AUS (Applications' Users system) module is not installed in any computer in the network, install it by running the program (setup.exe) in aus folder of the CD.
If the module GAS (General Accounting System) is not installed in any computer of the network, install it by running the program (setup.exe) in the GAS folder of the CD.
If the neccessary accounts to run the HFO modules are not define, define them before running HFO modules. The accounts required are client account, Banks Account, and Cash Book Accounts. At least the hotel clients must be defined but it is recommended to define banks and cash books. Also you have to define deferrent Credit Cards if you are going to use Credit Card Payment Method for bills.
If the module HBD (Hotel Basic Data) is not installed in any computer of the network install it by running the program (setup.exe) in HBD folder of the CD.
If the Hotel basic data, like taxes, room types, rooms, ... etc. are not defined yet, define them using HBD module before using HFO module.
Run the program (setup.exe) in the modules folder. This program will install the module into a fixed drive in the computer.
A user of type adminstrator must run the program HFO for the first time. In this run a registration form opened to enter the registration data like Hotel name and Adminstrator name and password.
Administrator must define other non adminstrator users using AUS module and define their authorizations. If the company profile is not defined, the adminstrator may also define it in AUS module. Company profile contains data such as logo, address, and others that will printed in bills.
Adminstrator must run HFO program in adminstration mode to define start and end hours of the hotel day, select printers for reports, define front office cash book, and any adminstrative data that might be used by the regular operator.
The regular Front Office clerk can now use the HFO program to perform the regular front office functions.


Outlet System Definition

Name: | Hotel Outlet
Code: | HOT
Version: | 1.0.0
Issue Date: | January 2003
Function:
Outlets are services offered to hotel guests like restaurants, coffee shops, laundries, telephones. This module can be used for restaurants, coffee shops, and laundries independently from the hotels. The principal function of this module is order processing and bills issue. It prints a closing account statement and a sold items report.
Requirements:

AUS | Application Users System and its database
ICM | Item Cataloge Management And its database
GAS | General Account System And its database.
HMSDB | HMS Database

Order a CD of the whole HMS 2003 for only the price of shipment and handeling.


Outlet System Definition

Name: | Hotel Group Reservation
Code: | HGR
Version: | 1.0.0
Issue Date: | January 2003
Function:
The reservation module has four levels of reservation. The highest level is for Clients (Agents or Tour Operators) to whom the guests belong. In the client level, users specify the client arrival and departure dates, number of rooms, and number of guests (pax). The system assigns reservation number and date that are used by all other levels of reservation. The second level is the level of room type. The users assign different room types along with arrival and departure dates, number of rooms, and number of guests (pax) for each room type. The system automatically assigns available rooms within the period specified for each type. The room reservation is the third level of reservation. The user may change the assigned rooms with the guide of a form displaying all the available rooms for the specified type for the period specified. The fourth level is the guest reservation. In this level, users assign guests to each reserved room. The first guest is considered the principal guest to whom the bill is issued. The users can change the principal guest if room has more than one guest.

After completing the reservation to the fourth level, the user can check in all guests defined when the status becomes ‘On Arrival”. The users also can check out all guests and rooms of status “On Departure”.

On check out, the system prints a client bill along with a bill for each room. The system also prints a reservation list on request and sends email to client.

Users can transfer focus to different forms displayed by pressing F5. The current form has different color (violet) of the bottom bar. The current form is one accessible to the users. The bottom bar of the other form has a black color.

Requirements:

AUSDB | Application Users System database
GASDB | General Account System database.
HMSDB | HMS Database
GAS | General Accounting System is required for the definition of accounts used by the module like Client Account, Bank account, Cash Book Account.
HBD | Hotel Basic Data Module is required for the definition of room types, rooms, taxes and other basic data.
All databases should be defined with ODBC Manager with Data Source Name (DSN) ‘XXX’, where the three X’s represent the first three letters of the database file Name. For example AUSDB is define with DSN=aus.


Hotel Room Service

Name: | Hotel Room Service
Code: | HRS
Version: | 1.0.0
Issue Date: | January 2003
Function:
This module displays room layout by floors. The layout shows rooms status (Check In, Reserved (Confirmed and unconfirmed), Day Use, On Departure, On Prepartion, and On Maintenance. The status (On Prepartion) is assigned to rooms after check out and the module HRS clears this status after prepration of the room. The module also changes the status of the rooms to (On Maintenance) to prevent any operations on it untill the maintenace is complete. After maintenance completion the module records the maintenance items and their costs and clears the maintenance status. The module also isues a number of reports and inquiries like Guest list, Occupied rooms, Guest meals List, Vacant Rooms, Room Status Summary, and Resident Guests. The users of the module (HRS) can search by room number and/or Guest name.
Requirements:

AUSDB | Application Users System database
GASDB | General Account System database.
HMSDB | HMS Database
HBD | Hotel Basic Data Module is required for the definition of room types, rooms, taxes and other basic data.
HFO | Hotel Front Office Module is required for the Hotel operations that change the rooms status.
All databases should be defined with ODBC Manager with Data Source Name (DSN) ‘XXX’, where the three X’s represent the first three letters of the database file Name. For example AUSDB is define with DSN=aus.


Hotel Management Reporting

Name: | Hotel Management Reporting
Code: | HMR
Version: | 1.0.0
Issue Date: | January 2003
Function:
This module issues four types of reports: Operational Reports, Financial Reports, Management Reports, and Adminstrative reports. Users of this module may have limited authorization to print some reports types. The operational reports Include: Room Reservation Report, Settlement Payment, Cash Receipt, Shift Account Statement, Client Account Statement, Room Bill, Guest List, Occupied Rooms, Guest Meals List, Vacant Rooms, Rooms Status Summary, Resident Guests, Detailed Rooms Status, Standard Outlet Bill, Mini Outlet Bill, Outlets Account Statement, Outlets Sold Items. Financial Reports include: Occupied Rooms Account Statement. Management Reports include: Room Occupancy Rate and Users Event Log. Adminstration Reports include: Define Reports Printers.
Requirements:

AUSDB | Application Users System database
GASDB | General Account System database.
ICMDB | Items Catalogue database.
HMSDB | HMS Database
All databases should be defined with ODBC Manager with Data Source Name (DSN) ‘XXX’, where the three X’s represent the first three letters of the database file Name. For example AUSDB is define with DSN=aus.


Items Catalogue

Name: | Items Catalog Management
Code: | ICM
Version: | 1.0.0
Issue Date: | January 2003
Function:
This module is used to define all items and products of the organization. It also defines the units and unit conversion table. The stock control system, Material Supply Management, and Order Processing Systems Like Hotel Outlets use the items defined in this module for their operation, i.e. The items definitions are common and standardized within the organization. The module maintains a standard descriptive code for items. It also include inquiries about detailed information about items like on order, on stock, balances, average price, lead time, ... etc.
Requirements:
AUSDB Application Users System database
All databases should be defined with ODBC Manager with Data Source Name (DSN) ‘XXX’, where the three X’s represent the first three letters of the database file Name. For example AUSDB is define with DSN=aus.


Stock Control System

Name: | Stock Control System
Code: | ICM
Version: | 1.0.0
Issue Date: | October 2003
Function:
This module manipulates multi stores. It perofms stock count, adjustment, and items movement between stores and other entities like departements, clients, vendors. It posts the account transaction to the designated account.
Requirements:

AUSDB | Application Users System database
ICMDB | Items Catalog database
GASDB | General Accounting database
SCSDB | Stock Control database
All databases should be defined with ODBC Manager with Data Source Name (DSN) ‘XXX’, where the three X’s represent the first three letters of the database file Name. For example AUSDB is define with DSN=aus.


Material Supply Management

Name: | Material Supply Management
Code: | ICM
Version: | 1.0.0
Issue Date: | November 2003
Function:
The users of this module define Vendor Items and process purchase orders. The module posts the account transactions to Vendor accounts and store accounts on delivery phase of the supply process.
Requirements:

AUSDB | Application Users System database
ICMDB | Items Catalog database
GASDB | General Accounting database
SCSDB | Stock Control database
MSMDB | Material Supply database
All databases should be defined with ODBC Manager with Data Source Name (DSN) ‘XXX’, where the three X’s represent the first three letters of the database file Name. For example AUSDB is define with DSN=aus.


General Accounting System - GAS

Name: | General Accounting System
Code: | GAS
Varsion: | 1.0.0
Issue Date: | January 2003
Function:
 Define Account Types like client, vendor, cash, bank, ... etc. and account entities for each account type. Enters and updates account trnsaction for account entities. The system also defines credit cards and follow up checks.
Requirements:

AUS | AUS Application and database
GASDB | GAS database


About HSH

Helal Software House is a group of software developers. We are trying to get benefit of the advancements in Information Technology and adapt it to the end user. We provide in-house training, consultation, software development project management or supervising user development teams.

Our Products Include:
  • Hotel Management System - HMS
  • Radiography Center Management - RCM
  • Integrated Production System (IPS) for Candels Factories
  • Sales Management System - SMS
  • Integrated Commercial System (ICM) For Electricity Distripution Companies.
  • Arabic Grammar Checker (AGC)
  • School Demand & Distripution System (SDD)

    • 4 Abdel Haleem Newara
    Al-Nozha Al-Gadida; Cairo 11769; EGYPT
    Tel: +20 (10) 5234609; +20(2) 6249262

    7/7 STURT ST.
    CAMPBELLTOWN; NSW; 2560; AUSTRALIA
    Tel: +61 (2) 4627 0357; +61(4) 2533 6534; +61(4)1837 2535